Manic Digger

It is currently Tue Oct 24, 2017 4:05 am

All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: need help with my server
PostPosted: Tue Apr 15, 2014 10:32 am 
Offline

Joined: Tue Apr 15, 2014 10:23 am
Posts: 1
Everytime i want to run Manicdiggerserver.exe in linux (Ubuntu 14.4(open beta)) mono the following message pops up andi do'nt know how to fix it , because i cant find the package and the data
Code:
ENet.ENetException: The ENet native library failed to initialize. Make sure ENetX86.dll and ENetX64.dll are in the program directory, and that you are running on a x86 or x64-based computer.  If you are running on Linux, make sure the libenet.so.1 is in your path. On Ubuntu Linux, install the libenet1a package (1.3.3 or newer) if you haven't already. If you are running on MacOS, make sure libenet.dylib is in your path or program directory.
  at ENet.Native.ENetApi.get_Platform () [0x00000] in <filename unknown>:0
  at ENet.Native.ENetApi.enet_host_create (ENet.Native.ENetAddress& address, IntPtr peerLimit, IntPtr channelLimit, UInt32 incomingBandwidth, UInt32 outgoingBandwidth) [0x00000] in <filename unknown>:0
  at ENet.Host.Initialize (System.Net.IPEndPoint address, Int32 peerLimit, Int32 channelLimit, Int32 incomingBandwidth, Int32 outgoingBandwidth) [0x00000] in <filename unknown>:0
  at ENet.Host.InitializeServer (Int32 port, Int32 peerLimit) [0x00000] in <filename unknown>:0
  at ManicDigger.EnetNetServer.Start () [0x00000] in <filename unknown>:0
  at ManicDiggerServer.Server.Start (Int32 port) [0x00000] in <filename unknown>:0
  at ManicDiggerServer.Server.Start () [0x00000] in <filename unknown>:0
  at ManicDiggerServer.Program.ChildServer () [0x00000] in <filename unknown>:0
  at ManicDiggerServer.Program.Main2 () [0x00000] in <filename unknown>:0
  at ManicDigger.CrashReporter.Start (System.Threading.ThreadStart start) [0x00000] in <filename unknown>:0


Last edited by croxxx on Tue Apr 15, 2014 4:34 pm, edited 1 time in total.
added code block


Top
 Profile  
 
 Post subject: Re: need help with my server
PostPosted: Tue Apr 15, 2014 4:41 pm 
Offline
User avatar

Joined: Wed Feb 22, 2012 4:17 pm
Posts: 381
Hi SonicEXE!

Setting up a linux server is quite easy.
All you need to run it are the following packages:
Code:
mono-complete
libenet1a

You can install these by opening a console window and typing:
Code:
sudo apt-get install <package_name_without_brackets>

I hope I could help you. If you've got further questions, feel free to ask ;)


Regards,
croxxx

_________________
Manic Digger Developer and Forum Moderator
Founder of the Pixolia Network

For mod updates (and other ocassional ramblings) follow me on Twitter: @THEcroxxx
Sometimes streaming stuff on Twitch
Homepage: croxxx.tk


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group